5

1995 Chevy S-10 Blazer - 4.3 L Vortec V6 (vin W with PCM) - This is the distributor style with vertical cap posts. 230,000 miles original owner.


EDIT: Please click on link below to see a photo of distributor. It is the "DI" style, not "HEI", "HE" or "HVS". There are no mechanical counter-weights inside this unit. AFAIK, all timing is advanced by computer control.


Without going into the detailed recent history, I believe I've checked, replaced, and eliminated every other source or possible cause of my rough idle condition. I narrowed it down to the distributor based on a lot of up/down play in the original, and I assumed gear wear, which gave me what seemed like a huge amount of rotational play (~ 3 to 6 degrees).

So I replaced my original distributor with a Cardone Select part #84-1635. Not a rebuild, but supposedly "brand new". The truck definitely runs a lot better, but still not as smooth as I expected considering how many things were checked and fixed. (Yes, it's been timed to the factory spec of 0 TDC at idle (~650 RPM) with the computer timing wire unplugged.)


Since the computer timing wire was disconnected, I did not expect to see any advance on acceleration from idle, yet my timing light shows a timing advance. How can the timing advance by itself when the computer timing wire is unplugged?

With the computer timing wire plugged in, the timing mark seems to jump around. Is this normal? I was expecting the computer to advance/retard timing smoothly with engine acceleration, not jump back & forth.

  • Do these two observations indicate excessive distributor slop?

Up/down shaft play on the original distributor is measured at 0.032" and not a huge amount of gear wear. For the number of miles and reading about how these gears wear out, I was expecting a lot worse.

Up/down shaft play on the new distributor is 0.021" <- this still seems like a lot to me, but I'm not sure

Since there was not nearly as much gear wear as I was expecting to see, I'm doubting and second-guessing this new distributor or that I've done everything possible short of an engine rebuild.

  • What is the amount of up/down shaft play supposed to be? Is there an acceptable range?

Also, there is a tremendous amount of slop in the engine block hole where the distributor is inserted. The hold-down clamp is firmly holding the distributor in place, but when this clamp is loosened, the entire distributor moves side to side. Don't get me wrong, there is zero side-to-side in the shaft itself. I'm just talking about the entire distributor assembly moving side to side and back & forth in the hole after the gear is meshed and fully seated. Is this normal? I was expecting the ring under the collar to fit snugly in the hole on the top of the engine block. I should have tried fitting the original one back in just to answer my own question; and now I regret that I did not.

  • With the clamp loosened and the collar seated down firmly on its gasket, mine is very sloppy all around (+/- 1/8"). In other words, the hole is way oversized... is it supposed to be like this or is there something wrong with this new distributor? I assumed the distributor assembly supposed to fit snugly into the top engine block hole.

  • Edit: This third question was resolved by simply inspecting the original gasket. There is a circular indentation in the original gasket that is offset about 1/16" from the center point. In other words, the original distributor was also not self-centering in the engine block hole.


EDIT 2:

While at Auto Zone today, I asked to see the Duralast distributor. It's new (not rebuilt) and I believe made by Spectra since it used the same photo and part number. I did a really quick check on the up/down play and it was more than 0.030". That's about the same as mine with 230,000 miles. Either it does not matter and they all have a lot of slop, or these imported replacements are not up to spec. This is what my question here is mostly about... the correct GM specifications.


EDIT 3:

Remaining roughness in the idle was finally tracked down to a loose heat shield that was intermittently shorting out the spark plug boot for cylinder #4.


EDIT 4:

It wasn't long after my last edit that the overall roughness came back with a vengeance. White exhaust smelled of gas and I was completely out of ideas...

See "Edit #3" on my other question for the root cause.

4

(EDIT NOTE: I made a bad assumption about the HEI distributor, so deleted all of that nonsense. Please do the following to see if it is an issue, though.)

Please check the following:

  • Take the distributor cap off so you can observe the rotor
  • Put a socket on the crank shaft snout bolt (where the main crank pulley is at)
  • Turn the crank clockwise until you see the distributor move
  • Turn the crank counter-clockwise until you see it move

How many degrees of crank shaft turn has occurred between the two movements? It should be zero (it should start moving right away as you turn it CCW). If there is any turn in there, your timing chain is worn out and is probably causing not only ignition timing issues, but also valve event timing issues. At 230k miles, it is not unheard of for the timing chain to be worn out.

  • Thank-you for your answer. However, my truck (vin W) has the DI style ignition, not the HEI. I can also confirm that there are no counter-weights within the distributor. – Sparky Jul 6 '15 at 14:11
  • I've also read on the S-10 and Blazer forums that this engine's timing chain has a tensioner and is never supposed to need replacement. However, I'll do your suggested test next time I have the cap off. – Sparky Jul 6 '15 at 14:21
  • Yes, then disregard what I said about the HEI ... was a bad assumption on my part. As far as the timing chain goes, everything I'm showing has it just like any other SBC/4.3L-V6 I've seen: two gears and a chain. When new, there's not enough slack to have a tensioner on it, nor does it come in the timing chain kit. – Pᴀᴜʟsᴛᴇʀ2 Jul 7 '15 at 0:23
  • 1
    Yes, my GM service manual is showing exactly what you describe. The new distributor did make a huge performance difference for whatever reason... maybe the slight gear wear was the problem. Next time I have the cap off, I'll rotate the crank to see how much slack I have in the chain. – Sparky Jul 7 '15 at 0:29
  • Still have not had a chance to check the rotational slack in the chain. However, the GM service manual implies that the chain does not need replacement until the chain can be 'moved back & forth in excess of 5/8"'. So my question is, how much rotational slop corresponds to 5/8" of back & forth? Is it still close to zero? When the chain is new, how much can it be moved "back & forth"? – Sparky Jul 7 '15 at 15:05
1

The following two items are the exact replacement for various year/make/models of GM vehicles with a 4.3 L engine, including my 1995 Blazer (vin W with PCM)...

What is an acceptable amount of up/down play in a distributor shaft?

I contact both Spectra Premium and Cardone several days ago. I never heard back from the Cardone representative. However, after much email back & forth with a representative of Spectra Premium, I got the answer.

According to their supplier, the actual GM spec for endplay on this particular model of distributor is:

0.024" - 0.047" (0.6mm - 1.2mm)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.