3

I recently installed an engine (complete from oil pan to the valve cover) from a 2010 Malibu in my 2006 Solstice. (Replacing a blown engine.) The car will not crank / turn over.

Symptoms include:

  • My scanner (HP tuners) reports no DTCs, and my CEL is not lit.
  • No security light, though this was formerly lit when I had not properly reconnected the BCM connectors between the chassis/body harness and engine harness.
  • Fuel pump is also not being activated
  • When turning the key, I can hear relays clicking from the fuse block under/behind the passenger floorboard as well as from the fuse block in the engine bay.

Also,

  • Lights work.
  • Instrument cluster does it's POST thing when turning the key to "start" or "run." (Gauges sweep all the way to the right then back to zero. All lights are tested. DIC shows "Solstice" and then the odometer reading. (I would probably get a "ding ding" with the door opened if I had not removed the stock stereo, which I have not replaced.)
  • Windshield wipers work. In fact, as far as I can tell, everything else works.
  • There is +12V at the starter (tested with multimeter, and since the engine turns over when shorting (welding!) the starter posts.)

I lost the fuel pump relay, so moved the one for the electric trunk release into the fuel pump spot. They had the same part number and looked identical so I doubt this is the issue.

Car has a new battery (fully charged) and a new starter (properly connected). I can turn the engine over by shorting posts on the starter but, with no fuel, of course it won't start.

At one point when the security light was on (which I assume was just due to the BCM connector not being properly seated), I tried the 30 minute key relearn procedure, just before I found the BCM connector issue and fixed it. I don't suppose it's possible that the car is stuck in relearn mode following a week if sitting?

I'm at a loss as to how to proceed. If anyone has any suggestions, or a place where I can find a diagnostic flowchart for this car, I would be eternally grateful.

    -
  • That's an epic level of detail, good stuff! – Zaid Jun 11 '15 at 18:11
  • Have you looked at the security system at all? Could be a start interrupt causing your no start issue. Maybe a blinking security light? – Pᴀᴜʟsᴛᴇʀ2 Jun 11 '15 at 22:15
  • @Paulster2 no security light. :( – 3Dave Jun 11 '15 at 22:27
  • Is there a little lock light illuminated on the dash? It might look like this. – Pᴀᴜʟsᴛᴇʀ2 Jun 11 '15 at 22:39
  • When you replaced the engine, what did you do with the Engine control unit? – knocksAndMisfires Jun 12 '15 at 5:41
2

Well:

When I reinstalled the engine harness and connected it back to the engine bay fuse block, I didn't properly tighten the five bolts that secure the connectors to the fuse panel. Apparently it was therefor not correctly grounded.

Yay. Thanks everyone for the help!muahaha

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.