0

I have a 2007 dodge ram 1500 hemi. When I accelerate hard I hear a slapping noise when it shifts, it also clunks when shifting if I let off the gas during a shift

  • 1
    Is it an automatic? – Shobin P Jun 11 '15 at 6:23
  • Yes automatic 4×4 slt – Kevin Jun 11 '15 at 10:53
1

From the sounds of it, you have a bad motor mount or transmission/transfer mount. The easiest way to check these is by having a friend help you:

  • Have someone in the cab behind the wheel
  • Start the truck and put the parking brake on
  • While observing on side motor mount, put the truck in drive
  • See if the motor mount has excess movement (does the engine look like it's lifting?) - the person behind the wheel can possibly rev the engine a little bit to enhance any movement
  • Place the truck in reverse and repeat the above step
  • Check the transmission/transfer mount using the same method

If this doesn't pan out, there may be an issue with your U-joint(s). To check these, put the parking brake on and put the transmission in neutral (engine does not need to be running, but truck should be on level ground). Here, you are taking the pressure off of the drive line. Get underneath your truck and wiggle the drive line at the U-joints, also turning it back and forth. You are looking for any kind of movement at the joint. It should be solid.

Ultimately, the only way you are going to be able to tell is by observing what is going on with the truck, under and around it.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.