2

This is a bit of a strange problem but the left turn signal on my '98 Saturn SW2 is acting a bit funny. When braking the blinker will either simply not work or work very slowly. When not braking it will usually work like usual but other times it will blink at 2x speed. I cant figure out what could be causing this problem only with my left blinker. Where would the division be in the electrical system that can allow for this strange isolation of behavior.

5

I'd check the ground strap/contact to ground from the blinker to the chassis first. Chances are there's a problem with it an it "grounds" via another bulb when you also apply the brake.

Using a multimeter, check the resistance from the ground on the bulb holder against the chassis first, then check blinker ground against both contacts for the brake light. Chances are that one of them will show a high resistance when it shouldn't and one to the brake light will show low resistance only with the brake applied.

|improve this answer|||||
  • This was (mostly) it. The problem was the ground but the location was in the wire itself. I don't know how but when I bend the ground wire it sometimes works better, and other times worse.I wouldn't think that a wire that never moves could become unreliable but there it is. – Bob Roberts Aug 22 '11 at 18:56
  • That's an almost perfect description of a broken wire - I'd find out exactly where the break is and carefully solder in some new wire or at least solder the break. – Timo Geusch Aug 22 '11 at 19:49
1

A problem with your charging system, such as an alternator that's not providing enough juice, can cause this. Your turn signal relays are sensitive to voltage fluctuations.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.