5

I have Subaru Impreza 2.5i (2.5 NA). My car's engine sputters a bit when turning it off. Specifically it seems like the cars engine keeps turning for a little longer right after I remove the keys.

  • There don't seem to be any issues starting the car or driving it around.

  • There are no CELs

  • The only thing I can think of that's a little strange in the car's recent history is that I put in premium high octane fuel (the gas station was out of regular). I can't definitively connect the two incidents though. In between doing that and now, I also had to boost the car once since it was really cold. I don't know if the ECU reset with a premium fuel type would do anything... again, can't really connect the two. Its been long enough though that I think everything should be calibrated anyway.

  • The engine has < 40,000 km on it and the car is completely stock.

What are some reasons the engine could be sputtering? What could I try to diagnose the problem?

3
  • possible duplicate of Car diesels after shutoff
    – jscs
    Mar 7 '15 at 9:15
  • Is there nothing I can do to try and diagnose the problem a little more on my own? What are some steps a mechanic might take if I took the car to a garage?
    – Pris
    Mar 7 '15 at 14:10
  • Come over to the Chat. Mar 7 '15 at 14:20
1

Its called in the UK "running on". Though I am not a Suburu expert, this is usually caused by a weak mixture,inlet air leaks, wrong grade spark plugs,wrong grade fuel,over advanced ignition timing, glowing carbon hot spots in the combustion chamber, leaking fuel injector, overheating engine, or on some engines a electric inlet suction break valve failing. Take the vehicle out for good long high speed drive and see if it helps, after that its electronic diagnostic checks on the system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.