6

I recently bought a used 2002 Citroen Xsara 2.0 Exclusive (petrol) which had a single electrical issue; the rear wiper did not stop in the "park" position but rather timed out in a random position. Research suggested that a wire could be broken and it should be a simple fix. I have found the broken wire but haven't gotten to fix it yet.

Lat week I changed the timing belt. I disconnected the battery and did the job (including oil change etc.) Guess it took 5 or 6 hours before reconnecting the battery.

However, problems began! The remote was not able to lock / unlock the doors but central locking still worked using the key. The engine would turn over but the engine immobilizer prevented it from firing (Engine immobiliser fault shown in console.) The car was towed to an authorized garage to reset the immobilizer.

Yesterday the garage called that the immobilizer was now reset and the car was once again able to move under its own steam. They informed me that the console read Eco mode active but the hadn't investigated further. It was arranged that I should pick up the car and arrange time for further investigation.

When picking up the car the following took place:

  1. Central locking didn't work (neither via remote nor by key)
  2. The car started and the display read Eco mode active
  3. Nothing worked: No lights, no wipers, no indicators
  4. I drove ~30 metres then all gauges and lamps in the dash died (RPM, speedo, etc.) except for the "battery discharge" indicator

Needless to say I left the car at the garage and are now waiting for news. But I'm wondering if anyone has knowledge of similar scenarios? Did I cause all this by simply disconnecting the battery?

Keep in mind that all work done on the engine was external: timing belt, water pump, coolant, oil, oil filter, air filter, spark plugs, generator belt, etc. (Oh well, I did disconnect a fuel line but it had nothing to do with electrical connections.)

  • Maybe you happened to be really unlucky and it somehow left the BSI in an inconsistent and irrecoverable state... by the way, did you try disconnecting the battery and letting it rest for a few hours to try and reset the BSI yourself ? They keep most of their state in RAM (at least, the current run time data, the config is of course in ROM but will only be changed when explicitly asked by the diagnostic device) which means power cycling them should bring them back to normal. – user5106 Mar 8 '15 at 23:38
  • @AndréDaniel I did try a fair amount of witchcraft but not disconnecting the battery for more than 5-10 minutes. – jensgram Mar 10 '15 at 5:38
  • Disconnecting the battery for a few hours should've fixed it. – user5106 Mar 10 '15 at 14:43
  • @AndréDaniel That's good to know. I'll keep that in mind. Thanks for the advice :) – jensgram Mar 11 '15 at 5:48
  • Perhaps you could answer your own question and award your self the answer. After that, throw down a new question regarding what you put into your update. Cheers and Happy Holidays! – DucatiKiller Dec 26 '15 at 22:25
1

The car is now fixed. The BSI (central computer) was totally reset / re-initialized and all is now good and well. The garage assured me that normally disconnecting the battery shouldn't leave the car FUBAR. They suspected the BSI had just entered some kind of extremely confused mode which demanded a hard reset.

So, I guess the answer was: Get the BSI re-initialized. Comments suggest, however, that it would have been worth trying to disconnect the battery for an extended period of time.

  • Thanks for coming back and sharing what the issue was. Very much appreciated. Happy New Year! – DucatiKiller Jan 7 '16 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.