4

I have a Craftsman 9hp dual (eg electric) start snowblower. It is very similar (or the same) as the one in this manual. It has been running smoothly all winter - I can start it reliably with the choke, a couple pushes of the primer, and one rip on the pull-cord.

Yesterday in the middle of cleaning the drive it stalled. I assumed that it was out of gas, but in retrospect there was no coughing - it just stopped without warning. Now I can't start it. I've added gas, and tried the electric start (which worked previously). The electric start does give a little 'click', but it never turns over.

The troubleshooting section of the manual isn't worthwhile. Any idea what the issue could be?

Update:

Since I posted this, I have tried (and failed) a couple times to re-start the snowblower. This weekend before going to borrow a neighbor's spark plug socket (and general mechanical knowledge), I tried it again and it started on the first pull. After an hour of work it died just as suddenly, and in the same spot.

Here's my theory. This day (just like the first time) was very light snow that blew around in clouds (see image). By the time the snowblower died, a lot of snow had landed on it and melted - there were puddles on the top of the engine. The snowblower died going about half-way up our medium-incline driveway (also see image).

I suspect that perhaps this melted water ran back onto something bad when I started going up the hill. Is that possible?

Snowblower where it stopped

  • 1
    I would suggest your battery or battery connection is at fault. While I see the parts list, I don't find a magneto setup which is usual for small engines. I don't find the alternator parts or a coil, either though. Just not sure at this point. – Pᴀᴜʟsᴛᴇʀ2 Feb 2 '15 at 22:55
  • 1
    If you pull the manual start can you get the motor to turn over (can you pull the rope at all)? – mikes Feb 3 '15 at 1:23
  • Good point, mikes. Hopefully it's not seized. – Pᴀᴜʟsᴛᴇʀ2 Feb 3 '15 at 1:28
  • @mikes Yeah, I was wondering that too. I can pull the cord and there is still oil on the dipstick. There are engine sounds while the pull-cord is being pulled, but it doesn't turn over or give any indication that it is likely to start. – doub1ejack Feb 3 '15 at 15:29
  • 1
    Remove the spark plug. Reconnect the plugwire back on the plug. With the plug laying on the engine, pull the rope and see if you have a spark at the plug. Let us know the results. – mikes Feb 3 '15 at 19:59
5

I probably have the same engine, is it the 9HP Tecumseh Snow King? There are several possibilities. Here is what you can do to debug the problem when it happens.

  1. Water intrusion to the ignition area. Pull the spark plug, put it against the block, and pull the starter while looking for spark. Best done in the shade. Better yet use an inline spark tester.

  2. Vapor lock. This is where the carb gets so hot, the fuel boils and a bubble blocks further fuel flow. These era Tecumseh's came with awful carburetors. Replace it. Engine will restart after it cools off.

  3. Overheat lockup. Try the manual pull starter. If it turns over (even if it doesn't start), this is not the problem. If it is locked up, you have to address the cause of the situation, either lack of oil or insufficient airflow for cooling.

Good luck!

  • 1
    Your really helping the site stats by going back and answering these old unanswered questions. Kudo's. You're the man. – DucatiKiller Jan 7 '16 at 3:45
  • It's only because I'm not fast enough to answer the new questions! lol – kmarsh Jan 7 '16 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.