4

I recently purchased replacement mirrors for my '99 Dodge Ram 1500. When I put the door back together and tested, I found that when I tried to move the mirror leftwards or upwards, the mirror on the driver side would not move. I then tried to move the right hand side, which moved properly for a minute but then also exhibited no left/up movement.

At first I was thinking that perhaps these new mirrors are faulty, but then I moved the control stick back to left-side operation and tried to move the mirror to the left. To my dismay, the RIGHT-side mirror moved left.

This leads me to believe that the mirror control unit is faulty, not the mirrors themselves, since my assumption would be that the left-right twist control on the control unit just alternates which set of wires to send the control signals. Can anyone confirm this and possibly give me the part number for the replacement mirror control?

  • 1
    Double check to ensure you have the wires hooked into the switch fully. It sounds like you are having a grounding issue which is allowing the power to flow through different conduits back to ground. – Pᴀᴜʟsᴛᴇʀ2 Aug 22 '14 at 20:16
  • That's an interesting idea that I did not consider. I think the switch is faulty, however -- I'm waiting for a replacement before going much further. – Peter Grace Aug 25 '14 at 15:40
2

Have you replaced complete mirror assemblies or just the mechanisms with the twin motors which the mirror glass clips into? On a lot of vehicles the mechanisms are identical whilst the shape of the glass is 'handed' to fit one side. If it is the mechanisms that have been changed their wiring is 'handed', and you may have them on the wrong side of the vehicle.

  • Complete assemblies. I looked up in the maintenance manual how to check the power mirror control unit and it looks like it is bad. I'm waiting until a replacement gets here to verify that and answer it officially. – Peter Grace Aug 25 '14 at 15:39
1

After checking the wiring harnesses, I found that one of the mirrors had a wire that the insulation had ripped and was pushing to ground. This, as Paulster2 mentioned in the comment to my question, was causing the weird behavior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.