2

I've seen questions about engines revving when braking and when idling, but my engine revs way up (and stays up) whenever it's in park--whether on startup or shifting to park. It doesn't rev unusually like this in any other gear. What would be the most probable reasons?

2000 Saturn SL1 with 204,000 miles.

2
  • Does it do the same thing in neutral? – Nate Eldredge Aug 15 '14 at 20:59
  • @NateEldredge Nope. Only in park. – LCIII Aug 15 '14 at 23:53
2

That particular engine (single cam) commonly has an intake gasket leak with high idle as a symptom. There are other common issues with the same behavior such as the throttle position sensor, idle air controller, and engine coolant temperature sensor. Some googling into saturn forums will provide more troubleshooting and info than I could in a reasonable-length post here.

2
  • 3
    You should really do the research and post it here. If you've read any of my posts, you'd know that "reasonable-length post" is subjective ;-) I would bet your answer is correct, fleshing it out a little bit will go a long way as to an actual answer. Besides, if you have the info, posting it here will keep people here instead of shooting them off to a different place on the internet. Remember to reference something if you pull it from another website, though. – Pᴀᴜʟsᴛᴇʀ2 Aug 15 '14 at 19:45
  • If the problem is high idle, wouldn't we expect to see the same behavior when in neutral? The OP says that's not the case. – Nate Eldredge Aug 16 '14 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.