2 added 58 characters in body
source | link

I've got a 2008 Chevrolet Cobalt. The passenger front blinker, passenger rear blinker & brake light, and the middle brake light are all out. The hazard lights also do not work on the passenger side.

I've looked at all the fuses I can find that remotely deal with lights in the floor panel & under the hood; no visual issues. I've looked at all the bulbs themselves, and none of them seem busted.

Does this sound like an electrical short somewhere? Maybe the turn signal switch? I don't really know where to start or where to look to diagnose the issue. Any thoughts?

I've got a 2008 Chevrolet Cobalt. The passenger front blinker, passenger rear blinker & brake light, and the middle brake light are all out.

I've looked at all the fuses I can find that remotely deal with lights in the floor panel & under the hood; no visual issues. I've looked at all the bulbs themselves, and none of them seem busted.

Does this sound like an electrical short somewhere? Maybe the turn signal switch? I don't really know where to start or where to look to diagnose the issue. Any thoughts?

I've got a 2008 Chevrolet Cobalt. The passenger front blinker, passenger rear blinker & brake light, and the middle brake light are all out. The hazard lights also do not work on the passenger side.

I've looked at all the fuses I can find that remotely deal with lights in the floor panel & under the hood; no visual issues. I've looked at all the bulbs themselves, and none of them seem busted.

Does this sound like an electrical short somewhere? Maybe the turn signal switch? I don't really know where to start or where to look to diagnose the issue. Any thoughts?

1
source | link

Passenger front blinker, rear blinker & brake, and middle brake lights all out

I've got a 2008 Chevrolet Cobalt. The passenger front blinker, passenger rear blinker & brake light, and the middle brake light are all out.

I've looked at all the fuses I can find that remotely deal with lights in the floor panel & under the hood; no visual issues. I've looked at all the bulbs themselves, and none of them seem busted.

Does this sound like an electrical short somewhere? Maybe the turn signal switch? I don't really know where to start or where to look to diagnose the issue. Any thoughts?