Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
2 whitespace
source | link

The factory plugs should be good for 100,000 miles / 160,000 km or so. They're ridiculously easy to change on a Zetec. If you can handle a screwdriver and a socket wrench, you can check / change them yourself. They're easily accessible from the top of the engine through holes in the valve cover. The plug wires are also easy to inspect, just keep track of which connector they should plug into on the coil pack and number them yourself if they don't have a number molded into them.

It's probably worth checking the idle air control valve. It should be on the driver side of the intake manifold, under the throttle body. Depending on what's in the way, it might be easier to access from under the vehicle.

The timing belt can cause all sorts of trouble, it's due before 100,000 miles (it will actually fail around that point if it's not been changed) but I don't remember the specific number. If you pull a code for the cam position sensor, I'd actually suspect the timing belt first unless it's nowhere near needing replacement.

As for the white smoke, could be steam, or you could be burning coolant. Keep an eye on your coolant levels. If you're loosing coolant, you're burning it or leaking it.
Other

Other than that, if your MAF sensor has never been cleaned, it might be worth picking up a can of cleaner specifically for MAF sensors. It's in the intake air path on the driver side, between the air box near the battery and the intake manifold.

That's all the generic Zetec tune up advice I've got. Report back with your mileage and have those codes pulled.

Update

I've seen that P0171 before on a Zetec. I'd guess that vacuum leak was on the hose going into the valve cover. As for the coolant leak, that sucks, but before you write the vehicle off, consider that the engine has been known to run for 250,000 miles without a rebuild (well, the 2.0L on the CDW27/Contour/Mystique/Mondeo anyway). Also, check out this thread. The owner has a 1.8L Zetec in a Ford Escort with a shop diagnosed head gasket leak. He tore the motor apart himself and couldn't find it. You might have a very small leak. It might be worth driving the vehicle for a while and checking the coolant loss rate (keep an eye on the level in the overflow tank in the engine bay, note the max and min markers). You might not have burned all the missing coolant, the thermostat housing (plastic box on the front driver side of the engine with a hose going into it) is a known weak point for leaks. If you're adding coolant, make sure to use the correct (50/50) mix of coolant and water. Given your year, you should have conventional green antifreeze.

The factory plugs should be good for 100,000 miles / 160,000 km or so. They're ridiculously easy to change on a Zetec. If you can handle a screwdriver and a socket wrench, you can check / change them yourself. They're easily accessible from the top of the engine through holes in the valve cover. The plug wires are also easy to inspect, just keep track of which connector they should plug into on the coil pack and number them yourself if they don't have a number molded into them.

It's probably worth checking the idle air control valve. It should be on the driver side of the intake manifold, under the throttle body. Depending on what's in the way, it might be easier to access from under the vehicle.

The timing belt can cause all sorts of trouble, it's due before 100,000 miles (it will actually fail around that point if it's not been changed) but I don't remember the specific number. If you pull a code for the cam position sensor, I'd actually suspect the timing belt first unless it's nowhere near needing replacement.

As for the white smoke, could be steam, or you could be burning coolant. Keep an eye on your coolant levels. If you're loosing coolant, you're burning it or leaking it.
Other than that, if your MAF sensor has never been cleaned, it might be worth picking up a can of cleaner specifically for MAF sensors. It's in the intake air path on the driver side, between the air box near the battery and the intake manifold.

That's all the generic Zetec tune up advice I've got. Report back with your mileage and have those codes pulled.

The factory plugs should be good for 100,000 miles / 160,000 km or so. They're ridiculously easy to change on a Zetec. If you can handle a screwdriver and a socket wrench, you can check / change them yourself. They're easily accessible from the top of the engine through holes in the valve cover. The plug wires are also easy to inspect, just keep track of which connector they should plug into on the coil pack and number them yourself if they don't have a number molded into them.

It's probably worth checking the idle air control valve. It should be on the driver side of the intake manifold, under the throttle body. Depending on what's in the way, it might be easier to access from under the vehicle.

The timing belt can cause all sorts of trouble, it's due before 100,000 miles (it will actually fail around that point if it's not been changed) but I don't remember the specific number. If you pull a code for the cam position sensor, I'd actually suspect the timing belt first unless it's nowhere near needing replacement.

As for the white smoke, could be steam, or you could be burning coolant. Keep an eye on your coolant levels. If you're loosing coolant, you're burning it or leaking it.

Other than that, if your MAF sensor has never been cleaned, it might be worth picking up a can of cleaner specifically for MAF sensors. It's in the intake air path on the driver side, between the air box near the battery and the intake manifold.

That's all the generic Zetec tune up advice I've got. Report back with your mileage and have those codes pulled.

Update

I've seen that P0171 before on a Zetec. I'd guess that vacuum leak was on the hose going into the valve cover. As for the coolant leak, that sucks, but before you write the vehicle off, consider that the engine has been known to run for 250,000 miles without a rebuild (well, the 2.0L on the CDW27/Contour/Mystique/Mondeo anyway). Also, check out this thread. The owner has a 1.8L Zetec in a Ford Escort with a shop diagnosed head gasket leak. He tore the motor apart himself and couldn't find it. You might have a very small leak. It might be worth driving the vehicle for a while and checking the coolant loss rate (keep an eye on the level in the overflow tank in the engine bay, note the max and min markers). You might not have burned all the missing coolant, the thermostat housing (plastic box on the front driver side of the engine with a hose going into it) is a known weak point for leaks. If you're adding coolant, make sure to use the correct (50/50) mix of coolant and water. Given your year, you should have conventional green antifreeze.

1
source | link

The factory plugs should be good for 100,000 miles / 160,000 km or so. They're ridiculously easy to change on a Zetec. If you can handle a screwdriver and a socket wrench, you can check / change them yourself. They're easily accessible from the top of the engine through holes in the valve cover. The plug wires are also easy to inspect, just keep track of which connector they should plug into on the coil pack and number them yourself if they don't have a number molded into them.

It's probably worth checking the idle air control valve. It should be on the driver side of the intake manifold, under the throttle body. Depending on what's in the way, it might be easier to access from under the vehicle.

The timing belt can cause all sorts of trouble, it's due before 100,000 miles (it will actually fail around that point if it's not been changed) but I don't remember the specific number. If you pull a code for the cam position sensor, I'd actually suspect the timing belt first unless it's nowhere near needing replacement.

As for the white smoke, could be steam, or you could be burning coolant. Keep an eye on your coolant levels. If you're loosing coolant, you're burning it or leaking it.
Other than that, if your MAF sensor has never been cleaned, it might be worth picking up a can of cleaner specifically for MAF sensors. It's in the intake air path on the driver side, between the air box near the battery and the intake manifold.

That's all the generic Zetec tune up advice I've got. Report back with your mileage and have those codes pulled.