403 reputation
3821
bio website
location New York, United States
age
visits member for 3 years, 1 month
seen Jan 18 at 0:27

Jan
28
awarded  Popular Question
Nov
25
awarded  Notable Question
Aug
13
awarded  Critic
Aug
12
awarded  Famous Question
Jul
1
revised Is Prestone “All Makes/All Models” coolant *really* compatible with all models?
added 155 characters in body
Jul
1
comment Is Prestone “All Makes/All Models” coolant *really* compatible with all models?
Deionizing water is just a cheaper way of removing salt ions to approximate distilled water. The only difference between deionized and distilled is that deionized has more non-ionic contaminants like organic stuff and bacteria. I don't believe there will be any differences as you state.
Jun
18
revised How does low oil level cause misfires or VTEC malfunctions?
low lol level?
Jun
18
accepted How does low oil level cause misfires or VTEC malfunctions?
Jun
17
awarded  Yearling
Jun
14
comment How does low oil level cause misfires or VTEC malfunctions?
Obviously I'm going to check the oil a lot more often now. I last checked it 2 months ago and it was a normal level, so I have to figure out what's going on with that.
Jun
14
asked How does low oil level cause misfires or VTEC malfunctions?
Jun
12
comment Is Prestone “All Makes/All Models” coolant *really* compatible with all models?
Yes, but that says the problem is actually the caps and recovery bottles that were introduced at the same time.
Jun
12
comment Is Prestone “All Makes/All Models” coolant *really* compatible with all models?
I've read all the DexCool stuff for my old Chevy Cavalier and it's all hearsay with no concrete proof of anything
May
17
revised What would cause a car to lose power a few seconds after starting, then run normally?
updatez
May
17
comment What would cause a car to lose power a few seconds after starting, then run normally?
@Tim: I tried to check the wires and then realized it doesn't have wires; it's coil-on-plug. :D I checked the plugs and they seemed normal.
May
17
comment What would cause a car to lose power a few seconds after starting, then run normally?
I took out all the coils and looked for cracks, but there was nothing obvious. I also misted the engine with water while it was running and didn't see any sparks or hear any power drop or anything. It does seem to happen more often while it's humid, though.
May
16
awarded  Notable Question
May
14
awarded  Famous Question
May
3
revised Check Engine code P0420 Catalyst efficiency below threshold bank 1
added 876 characters in body
Mar
31
awarded  Popular Question