179 reputation
7
bio website HelloChameleon.com
location Pacific Northwest
age 36
visits member for 1 year, 11 months
seen Jun 11 at 16:02

Branding and UX designer. Obsessive typophile. Color theory junkie. I spend my days mediating the treaty between logic and creativity.


Jun
7
awarded  Popular Question
Apr
14
awarded  Autobiographer
Dec
24
comment 2003 Yukon XL 1500 5.3L Very rough, unstable idle on cold starts
@timogeusch not even close. It was just surface grime. A few swipes with a cleaner doused shop rag did the trick.
Dec
20
comment How to prevent body damage and rust from salted roadways?
Trade up to a DeLorean! Oh, wait ... you don't want your chasis to rust either?
Dec
20
awarded  Scholar
Dec
20
accepted 2003 Yukon XL 1500 5.3L Very rough, unstable idle on cold starts
Dec
19
comment Switching gears without clutch
Mine was a V8 so those pistons were hanging on for dear life at 5 and hoping not to meet the valves!
Dec
19
awarded  Self-Learner
Dec
19
comment 2003 Yukon XL 1500 5.3L Very rough, unstable idle on cold starts
Looks like that did it. I've scrubbed throttle bodies many times before, even some really dirty ones, but I've never seen such a dramatic result. I had no idea a little surface grime could destroy cold idle.
Dec
19
answered Switching gears without clutch
Dec
18
awarded  Teacher
Dec
18
comment 2003 Yukon XL 1500 5.3L Very rough, unstable idle on cold starts
@mac When my idle first started getting choppy on cold days I had all the pertinent sensors checked out. Of course, that was several months ago.
Dec
18
answered 2003 Yukon XL 1500 5.3L Very rough, unstable idle on cold starts
Dec
18
awarded  Editor
Dec
18
comment 2003 Yukon XL 1500 5.3L Very rough, unstable idle on cold starts
5.3l, just added to the title.
Dec
18
revised 2003 Yukon XL 1500 5.3L Very rough, unstable idle on cold starts
edited title
Dec
18
awarded  Student
Dec
18
asked 2003 Yukon XL 1500 5.3L Very rough, unstable idle on cold starts