Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 2000 Hyundai Elantra, just yesterday and today I've had a few instances of sudden loss of power.

Driving along, the engine will run rough for about 10 seconds then just die all together. No warning lights etc on the dashboard. I noticed today that when it happened the Electric wipers went very very slow at the time. I pulled over, and it started fine again and was on my way, about 2 minutes later the same thing, this time however it won't restart and I notice when I turn the key I can not hear the fuelpump priming like I normally would. I would suspect the fuel pump however it was replaced only a couple of months ago. I give it a few minute try again and it starts. This time I just sat on the side of the road, waited 2-3 minutes and it went rough and died again.

Temp reading on dashboard is normal, never went much above the mid line.

What should I be looking at ?

share|improve this question

closed as too broad by Zaid, vini_i, DucatiKiller, Pᴀᴜʟsᴛᴇʀ2, Fred Wilson Dec 14 '15 at 4:04

There are either too many possible answers, or good answers would be too long for this format. Please add details to narrow the answer set or to isolate an issue that can be answered in a few paragraphs.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I'm wondering if you got some water in your gas. – Pᴀᴜʟsᴛᴇʀ2 May 13 '14 at 14:20

Browse other questions tagged or ask your own question.