Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

Hi I have 98 Nissan Maxima. I recently changed the thermostat in it and ever since then my fans will stay on, and I am not running the a/c either. Can you please tell me what could be causing them to turn on and stay on? This did not happen until after the thermostat was changed. Thank you.

share|improve this question
    
Are you talking about the fan for radiator or the cabin heat/AC? When you say all the time, do you mean even when the car is turned off? –  James Jenkins Mar 24 at 15:01
1  
The first thing that comes to mind is that you have bought a colder running thermostat. For instance, my car has three thermostats to choose from: 82, 87 and 92 Degrees Celsius (whatever that is in fahrenheit). Like it says on the tin, the 82 degrees thermostat will open when the coolant temp reaches 82 and will engage the fan soon after. 82 is very easy to reach in warm to hot weather (my car was designed to run at 92, mind you). Ask the shop you bought the thermostat from if they gave you a colder running item. If not, then there's something else, but this is the most likely explanation. –  Juann Strauss Mar 24 at 16:26

3 Answers 3

Were there any other repairs/maintenance done prior just before the problem started? If not, it sounds like the wrong thermostat has been installed, or the new one is faulty.

What caused you to change the thermostat?

share|improve this answer

You should check if the coolant liquid is between minimum and maximum. If you need to add more liquid, don't mix different liquids colours (I don't remember why). And please be sure it's not hot, else you will get very bad burns and injuries.

share|improve this answer

Sounds like you had an air bubble trapped in the cooling system after changing the thermostat. Check the coolant level. (Id also make sure the coolant temp sensor connector is hooked up, maybe it was left unplugged)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.