Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I have a 1996 Pontiac Sunfire with the 2.2L engine. When I accelerate slowly the engine seems to run fine. However, if I accelerate quickly the engine seems to hesitate. I have already replaced the MAP sensor and the air intake/charge temperature sensor.

Is there something else I should try to resolve this issue?

share|improve this question
    
When you say, hesitate, does it bog down, as in, takes a long time to speed up? Or does it bog for a second, then sort of take off? At this point, I'd be leaning towards a throttle position sensor. –  Paulster2 Mar 13 at 0:56
    
Um, if I accelerate quickly it will be like I no longer have the power it usually does to accelerate and the car kind of shudders then usually will smooth out. It will also exhibit the same type symptoms if I am going up a hill and downshifts. Also, like I said if I accelerate gently it seems to be fine. –  Michael Mar 13 at 1:36
    
Sorry, if my description isn't the best. I'm not sure the best words to use to convey the symptoms I am seeing. –  Michael Mar 13 at 1:36
    
Your description is fine. I was just trying to help you get more, stuff you might not understand to explain. Are there any engine codes (check engine light - CEL)? When was the last time it had a sparkplug/wire/O2 change (how many miles ago)? –  Paulster2 Mar 13 at 10:30
    
Spark plugs are new, and the plug wires are less than two years old (I don't remember exactly how long). It has been at least 5 years on the O2 sensor. –  Michael Mar 13 at 12:32
add comment

1 Answer 1

It could be the Throttle Position Sensor, when those go out, there seems to be a delayed response.

share|improve this answer
    
Which is why I suggested it in my comment. TPS's don't usually go bad per se, but rather get dead spots in them. This is why they behave strangely when they do. –  Paulster2 Mar 13 at 23:08
    
I replaced the throttle position sensor, and definitely have seen a difference (improvement) in throttle response. Will give it a few days of actual driving on it before declaring success. –  Michael Mar 17 at 17:11
    
Also test your distributor/coilpack. They usually only misbehave under high engine load until they're really bad and die outright. –  Juann Strauss May 13 at 9:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.