Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I have a 2006 Nissan Xterra with about 106,000 miles on it. For some reason, the car doesn't always start. I will try to start the car, and I can hear it attempting to start but it never does. Additionally, it almost always starts on the second attempt, if I wait about 20 seconds with the key out of the ignition.

I have recently replaced the battery, and it hasn't made any effect. There are no check engine lights on. When the car runs, it runs seemingly ok. There's no correlation between the cold or hot weather. It has been doing this in the winter, as well as the past summer.

Where can I start looking to diagnose this problem?

share|improve this question
2  
Something you can try before starting to replace parts is to do a Seafoam treatment. This can cure up a whole bunch of minor issues. –  Paulster2 Feb 25 at 12:06
add comment

3 Answers 3

up vote 1 down vote accepted

Since you already replaced the battery, one of the next reasonable plans of attack would be to see how dirty the air filter is or see if any of the spark plugs have been fouled. If you find the spark plugs or air filter are old, see if replacing them helps your issue.

After those steps, I would also investigate the fuel pump and the fuel pump relay if there is one.

share|improve this answer
    
Awesome stuff, thank you, I appreciate it! –  SSH This Feb 25 at 1:12
add comment

See what the spark plugs look like. Are they black and covered in soot/ Has oil leaked past the valve covers and soaked the plugs and wires/ are they wet and smell like gas? Spark plugs cans tell you a whole lot about your air/fuel mix and ignition. Id make sure to check fuel pressure too. make sure pressure doesn't drop too quickly after you turn off the car and stays within spec while the engine is running at all rpms. If it seems low, try replacing the fuel filter and inspect the fuel injectors to make sure they aren't leaking or clogged. Make sure the fuel filter isn't clogged. If theres no pressure at all (0 psi) then check to make sure the relay clicks when you turn the key to the ON position. If the relay seems okay then it's likely a fuel pump or wiring issue. Its never a bad idea to change air filters either, but you can just remove the filter and try to start the engine to determine if its causing the issue before you spend money. Just don't drive around without a filter in the car

share|improve this answer
    
+1 for fuel filter. –  hillsons Feb 25 at 1:32
add comment

there is a theft deterrent system built in the Ign switch with a chip in the key. - have seen wornout ign switches cause weak signals (lots of trinkets weight on keyrings). the way the question is worded, would indicate no spark on 1st try. Try timing light on any cylinder, and yes they do work on primary side of builtin ign coils, to check if spark present.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.