Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

Subaru Wagon Impreza 1996. Automatic, 1600cc.

  • The gas (refrigerant) has been refilled recently, so that's all good.
  • The air seems to be colder when the revs are higher (>2,500 rpm or thereabouts).
  • But then if I'm idling at a stop, the air seems to not be cold anymore.

I've also been able to make the air colder by simply switching off the aircon and switching it on again whilst driving.

I thought maybe it could be a fanbelt that is slipping, or worn? Do aircon's have fanbelts?

share|improve this question
    
Does the heat go cold at Idle also? –  mikes Jan 7 at 1:58
    
Yes, "idle" like when I'm stopped at the lights. The revs are just below 1,000 rpm and the air loses it's "coolth" –  Michael Jan 8 at 2:41
add comment

1 Answer

Several items to look into:

  • Even though your refrigerant has been refilled recently there is a chance that you have a leak and your compressor is cutting on/off. Double check that you still have adequate pressure.
  • If the air is only cold when you are moving then that might point to your radiator fans not running and pulling air across your condenser. Verify that the fans are running.
  • Yes, your A/C compressor runs on a drivebelt. It is never a bad idea to check your belts. Make sure they aren't worn and that the tension in the belt is still within specs.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.