Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

My 2007 Ford Ranger has no heat when I turn it on, but the COLD A/C works beautifully? All of the sudden the heat stopped working. It doesn't get humid or tepid at all, just no heat. What can I look at?

Keep in mind, it's not electrical, it's a manual knob. enter image description here

share|improve this question
    
So, it blows air, the air just doesn't get hot? –  BigHomie Nov 15 '13 at 20:13
    
it's almost as though (keep in mind its cooler here), that it blows cold air when I turn the knob to heat. –  Mike Nov 15 '13 at 20:16
    
Look under the hood and find the heater hoses. They will be about 1 1/2 inches across and go through the firewall. Feel if they are the same temperature or one hot and one cold. –  mikes Nov 15 '13 at 20:55
    
the one that comes from the radiator? its hot, but there is no hot air in the cab. –  Mike Nov 15 '13 at 22:42
    
they should be the smaller hoses that come off the engine and enter/attach to the firewall near the passenger side, –  mikes Nov 17 '13 at 0:06

2 Answers 2

Possible Causes:

  • Coolant Level
  • Thermostat stuck open
  • Heater Control Valve
  • Temperature blend door
  • Plugged heater core

Coolant Level

Coolant level that's even a little low can affect heater performance. It's near the top of the system so there could be enough coolant to prevent the engine from overheating but not enough to make it through the heater core.

Thermostat stuck open

If the engine isn't reaching operating temperature then suspect a stuck open thermostat.

Heater Control Valve

The heater control valve is inline with the inlet heater hoses running to the heater core. Look for 5/8 inch to 3/4 inch inside diameter hoses that pass though the firewall on the passenger side. Feel the one closest to the driver side at the firewall, this is the inlet hose. If this hose is not hot check the heater control valve. Follow that hose back until you find a valve that has a vacuum line attached to it. Make sure the line going into the valve is hot, if so then pull the vacuum line off the valve. There should not be vacuum present on the hose with the function knob in the floor position. If there is no vacuum on the valve, and the hose between the engine and the valve is hot at the hose between the valve and the firewall is not then you have a bad valve. If there is vacuum on the line then you likely have a bad function switch.

Temperature blend door

While that switch looks mechanical it's actually a potentiometer that controls the temperature blend door actuator.

This will require further testing, with a DVOM. Leave me a comment if everything else checks out.

Plugged heater core

If the inlet hose (closest to drivers side) is hot at the firewall and the outlet hose is only warm or cool you have a plugged heater core.

share|improve this answer
    
Let's say I take this to the shop, because some of these are out of my expertise. How much would I look to be paying on average for these services? –  Mike Dec 11 '13 at 18:57
    
@mike hard to say, they should charge you somewhere between half-hour and an hour labor to tell you what's wrong with it. They should be able to give you an estimate from there. –  Larry Dec 11 '13 at 19:13

Your air conditioning system has a valve that operates when you turn the AirCon on. The valve blocks hot coolant going through the cars interior heating system making the AirCon evaporators work(cooling) unaffected by the interior heating(heat). The fault will be amongst: AC switch not feeding the valve, wiring damaged or disconnected, valve failure closing off heater permanantly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.