Sign up ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I bought a '96 Toyota Camry about a month ago.

When I first turn the car on and the engine is cold, I can have the car stopped (in gear) and it will not shake. The idle RPMs will be at 1000.

After the car has heated up, I notice the idle RPM drop by about 250, and the steering wheel/car begin to rumble and shake. If I keep my foot on the brake and then tap the gas just enough to raise the RPMs back to 1000, the shaking stops.

In neutral or park (it's an automatic vehicle) the shaking diminishes but the RPMs do not rise from 750.

I was told the car had good even compression in the cylinders when I bought it from the dude, but you never know. Ideas?


share|improve this question
It may be a faulty ignition coil. They tend to misbehave when they're at operating temperature. –  Juann Strauss Oct 20 '13 at 16:44
Did you ever figure out what the problem was? –  vlsd Mar 13 '14 at 0:30
Well I got it checked out and the motor mounts/torque rod are definitely bad. I haven't gotten it fixed because I have -$ but the possibility still exists that it could be something else like a misfire or a vacuum leak. –  i-live-in-a-storm-drain Mar 13 '14 at 22:00

4 Answers 4

up vote 3 down vote accepted

I have a similar problem and haven't been able to figure it out yet, but here are the things I have tried and plan to try in the future. Some have helped marginally, some not at all, but they might work great in your case. If I left anything out, I'd love feedback!

  1. First thing to check is the engine and transmission mounts. If the engine shakes they are likely bad and need replacing (regardless of whether they are the cause or just a symptom) and that might fix your problem right there. An easy way to check the mounts is to have someone run the car while you're watching the engine with the hood open. Have the person rev the engine up and change between gears. If the engine jumps up and down at any of these actions one or more mounts is broken and needs fixed.
  2. Next, make sure your computer is not throwing any codes. If it is, this could save you a LOT of time. This case is usually hard to miss since it is (at least on my car) always accompanied by a check engine light on the dash.
  3. Spark problems: check your spark plugs or just outright replace them. Check your spark plug wires for resistance below 20KOhm and check for spark.
  4. Check the compression in the cylinders yourself, unless you trust the previous owner. No real reason to do all other hard work if this test fails.
  5. Dirty injectors/fuel system: try fuel system cleaners, see if that makes a difference. If it does, but not enough, you might need to do more serious work on the fuel line and injectors.
  6. Dirty/bad air intake components. Clean your throttle body, valves (especially the IAC), someone even suggested a full scrub of the whole intake manifold, something that is probably worth it anyway if you have the time (this is one of the things I plan on doing soon). Also check for vacuum leaks.
  7. Measure the ripple voltage that's coming from the alternator. Use the AC setting on a multimeter across the battery to do this while the engine is running (do NOT disconnect you battery while the car is running though!)
  8. Check the bearings that the various belts run over. I don't know how to do this other than listen to the bearings, but it makes sense that a bad bearing could put uneven load on the engine, especially at low RPM, and throw things out of whack.

Good luck and let us know what you find!

share|improve this answer

It's your transmission. Your torque converter is bad. There is too much torque as a result. When your car is in neutral or park there is no torque being created. When you leave the in gear idle state, the torque is relieved. That is why the problem will go away when you hit the gas. Hope this helps

share|improve this answer

I think @vlsd did cover most of the options but to expand a little bit.

When the engine is cold it has a lower fuel efficiency because is harder to burn the fuel (to illustrate... is easier to burn something up in a closed chamber in hell than in an artic pole), that's why your engine revs drop when you're at a red light, that's normal.

The thing with the shaking I think could be mainly by options 1 and 3 in @vlsd answer, although I'd check them in the inverse order, checking the mounts of the engine and transmission is significantly harder than just checking the spark plugs (although the mounts is a more likely reason).

It is said (and I have not many reasons to agree or disagree with this) that stopping your car and leaving it in a gear might loosen the mounts over the years, which makes some sense on its own... but then again, engine vibrations aren't necessarily reduced when accelerating.

share|improve this answer
Yeah options 1, 2 and 3 are the most likely. In my case they did not apply although the motor mounts were eaten through anyway. –  vlsd Oct 22 '13 at 19:53

Please help, may 1994 Nissan LEC is shaking every time I change gears. I changed all the engine/mount support but it is still shaking.

Anyone who can give me an idea what to do please...


share|improve this answer
Hello! This is not an answer, please ask a new question detailing your issue to get support! Take a bit going through this before asking - –  chilljeet Apr 30 at 5:01
If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. –  Gabriel Mongeon Apr 30 at 14:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.