Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I have a situation where I'm doing wiring for the dashboard of a vehicle. For whatever reason, the turn signal/headlight switch on this vehicle outputs a 6 volt signal on the high beam wire when the low beam is on and a 12 volt signal when the high beam is on. The headlights work as they're supposed to, but the high beam indicator led is activated when the low beam is on since 6 volts is enough to activate it. Does anyone have a simple solution to make the indicator only turn on when there is a 12 volt signal and not when it's a 6 volt signal?

share|improve this question
1  
What kind of vehicle is "this vehicle" –  cinelli Jul 12 '13 at 1:55
add comment

migrated from electronics.stackexchange.com Jul 11 '13 at 21:24

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

4 Answers

I'll expand on one of cinelli's comments - why not fix the cause rather than the symptom? If you've got 6v on the high-beam feed when the switch is set to dip, this suggests to me there is a problem with the switch - and I'd be worried that it might be causing other hidden problems.

For example, if the lamps aren't relayed (as is the case with a lot of older vehicles), you'll have 6v running through the high-beam filaments all the time the lights are on. This won't be enough to light them, but will shorten the life of the bulbs...

Have you tried another switch?

share|improve this answer
    
Got my approval +1 –  cinelli Jul 23 '13 at 13:26
add comment

Try putting a 6v2 zener (400mW) diode in series with the indicator LED. The LED takes about 1.5V so nothing under 7.7V should be able to turn it on. The LED current should be small enough to use a low power zener diode. Make sure you get the diode the right way around.

enter image description here

share|improve this answer
    
Though your solution may answer the OP's question, the real problem that needs to be solved is why is there 6 volts on a wire that shouldn't be there. We need more info to handle that. –  Mobius Jul 16 '13 at 11:32
    
@Mobius - That was not asked for in the OP's question. I have simply answered the question that was asked as per the guidance on answering questions. Perhaps the OP should ask another question - 'why do I have 6V etc..." and deal with it there. –  user3433 Jul 16 '13 at 11:59
add comment

If this is a simple logic chip that is detecting it, then you won't need a lot of current to trigger. In that case, just put something like two 1K resistors in series to ground and divide the voltage in half (the old output will now be in between the two resistors).

share|improve this answer
add comment

The indicator lamp on some vehicles is also illuminated if the resistance in the wiring is not equal to a certain amount. This is usually cause by using an incorrect bulb (even though the bulb will still plug in and work), If one of the connectors is corrodded etc. A little more details on the year make and model of the vehicle would be helpful. Finding and fixing whatever is wrong sounds a lot less of a hassle then soldering a diode in line to "mickey mouse" the fix.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.