Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I Have a Datsun Safari 1983 2,8L petrol.

Recently I was driving off road with it and the next morning the fan belt was making this squealing noise. So I adjust it and all was well. 300km later a new squealing sound started. It only occours when I drive over a speedbump or uneven surfaces and then I have to switch the engine of before this sound stops.

I checked to see if it could be the fan belt again or the starter motor or radiator fan but no. The sound of the starter motor or loosen fan belt is not the same and there is more than enough clearance between the radiator fan and its casing. My Datsun does not overheat or loose power when this sound starts.

Every time I drive it now this squealing sound is triggered more easily and becomes louder and louder. It also doesn't leak oil or water. There is only a small leakage in the braking system but the squealing sound doesn't came from the brakes,even when I come to a complete stop this sound will continue while the engine is running. I can't locate the source of this high-pitched squealing sound and this sound is of a sort that I have never heard of before anywhere. Its like when you making a squealing sound while keeping your nose closed.

share|improve this question
2  
Firstly, have you read the related question in the sidebar to the right? mechanics.stackexchange.com/questions/232/… –  Rory Alsop Apr 12 '13 at 15:15
    
i have a 1982 datsun diesel (d22 engine), i would presume its belt related. Not sure on the gas version but on mine the alternator has a oil line fed from the engine, i would make sure that its getting oil - also consider getting a belt dresser and spraying it on all of your belts. –  dashboard Apr 13 '13 at 5:00
add comment

2 Answers

It sounds like one of your pulleys is not securely mounted, and gets jostled into a position that causes it to bind when you go over a bump. Turning the engine off releases tension on the belt, which allows the pulley to return to its original position. Ensure that all the pulley bolts are torqued to the appropriate specifications (in the factory service manual). Try removing the belt and pull each pulley to check for looseness.

It's also possible that there is internal binding, possibly with the water pump or oil pump. The intermittent nature of the problem makes me hesitant to blame anything internal for this problem, though.

It's also entirely possible that the belt needs to be replaced. Since that's the simplest and least expensive option, start with that.

share|improve this answer
add comment

Just a guess... but you could have a stone caught between the fan belt pulley and housing

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.