Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I have a 2005 Ford Focus station wagon. The back windshield wiper slowly had started to cover less and less of the back windshield (up until yesterday it was only wiping the bottom 30% or so, the top 70% was completely missed because the blade was not connecting to the window).

I replaced the blade yesterday as my front both needed replacement about a year ago and I just knew we were going to have freezing rain while driving to work today. In this process, I more or less, well bent the back wiper assembly until it was working correctly - this included using a twist-tie to correctly apply pressure to get things to work.

While this might have "worked" I don't necessarily know if this is the correct way to fix this problem. Is there a more recommended strategy than this?

Here is a rough approximation of where the wiper blade was not hitting (everywhere above the red line):

enter image description here

Here's the blade itself. You can see the twist-tie. The arrow points to where I bent it out slightly to apply more pressure.

enter image description here

Note: the spring is completely clean (no dirt/ice/etc).

share|improve this question
    
Could you add a picture? It would be more clear about what's currently bent, zip-tied, etc. –  Bob Cross Mar 14 '13 at 13:35
    
@BobCross I will get a picture during my lunch break. –  enderland Mar 14 '13 at 13:41
    
See Rory's answer below: a picture of the spring part of the arm will make it clear if that's the issue. –  Bob Cross Mar 14 '13 at 14:46
    
@BobCross I edited the question. There is no dirt in the spring, however. –  enderland Mar 14 '13 at 18:04

2 Answers 2

The thing which typically causes this is the tension spring (which pulls the wiper towards the glass) becoming clogged with dirt. A good spray with a jet washer followed by application of a light lubricant should do the job.

With the wiper pulled away from the glass you should be able to see the tension spring - if not, you may need to disassemble the wiper unit (I'm not sure on that model)

share|improve this answer

Just replace your mangled rear wiper arm assembly and get a high quality wiper blade that doesn't have springs but rather uses the wiper blade's natural curvature itself as a spring. I have found these types of blades hug to the curvature of glass much better than the crappy $5 multispring wiper blades dated back to 60s

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.