Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I have a 1991 Honda Accord that started experiencing some electrical issues yesterday. At first, the right turn signal would not turn off. Shortly after, the turn signals stopped working completely but the hazard signals still work. Any idea which of the relays or fuses I should suspect?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Some cars have a separate flasher relay for the Hazards - if that's the case then you might have a failure of the primary flasher relay?

The signal initially not turning off suggests a possible failure of the switch though - It might be worth disconnecting the switch (there's usually a connection somewhere under the column) and testing it separately? I'm not sure about Hondas, but some cars of that age were known for the lighting stalk failing as they didn't have relayed headlamps, so the full current of the headlamp flowed through the switches - leading to failure as they get old!

share|improve this answer
3  
+1 It was the lighting stalk for me. –  Bob Cross Mar 1 '13 at 12:30
1  
Be very careful when probing in the column as you may accidently discharge the airbag. –  mikes Mar 1 '13 at 13:37
    
Sure enough, after taking out the switch it's evident that the problem was inside it. Not to worry mikes, there is no airbag. –  hillsons Mar 3 '13 at 5:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.