Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

My Mazda 626 is loosing power steering; however, it is NOT leaking under car. What's wrong?

I am not a mechanic; I'm puzzled why I'm loosing power steering fluid; however, it is not visibly leaking! I put power steering fluid in today; yet, it was hard to turn a few hours later.

share|improve this question
    
This problem is an on-going problem... It began months ago... I added power steering fluid once a month, then once a week, now it looks like daily... I only drive the car less than 500 miles per month... –  Patio Feb 14 '13 at 3:58
    
Note that you can edit to add to your own question. –  theUg Feb 14 '13 at 7:29

1 Answer 1

It might help if you give a little detail about your car generation or made year, since there might be variation on power steering system.

Does the car manual or auto transmission? Is it share power steering fluid with clutch fluid, leak might occurred at clutch cylinder where you might did'n look at.

Edit: read the problem description again and found that you have fluid lost but don't found any leak, sorry. Keep the previous answer just in cast that might help others


Assume your system is pure hydraulic-based. Power loss in hydraulic system might occurred without any leak due to worn/leak internal system. Or it can be from not enough power to drive the pump.

  1. Have you check the power pump belt?

  2. Have you look for any unusual thing that might block the steering rod or wheel from moving?

  3. Are there any unusual resistance to the engine (belt make noise) when you try to turn?

  4. The power steering is not assisted at all (like your didn't run the engine) or it lost some power?

PS. sorry for my bad English

share|improve this answer
    
My car is a 1997 Mazda 626, automatic transmission... The belt does make noise when I turn it and the fluid is low... –  Patio Feb 16 '13 at 7:18
    
My car is a 1997 Mazda 626, automatic transmission... The belt does make noise when I turn it and the fluid is low... I have not checked the power pump belt or if there is some blockage... It acts like there is no power sterring... –  Patio Feb 16 '13 at 7:28
    
When I start the car, the steering feels like a car without power steering...very difficult to turn... Thanks for directing me to possibilities to check... –  Patio Feb 18 '13 at 7:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.