Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I have a 2009 model Honda unicorn motorcycle. It's very difficult to ride during rain or cold weather, because of missing. I asked service center but they did not do anything. I have changed the CDI, ignition coil and air filter but the problem persists.

share|improve this question
add comment

3 Answers

Check the spark plugs and plug wires. Maybe you've got a bad plug or a wire with a crack in the insulation that's letting in moisture.

share|improve this answer
    
To diagnose cracked wires, its best to check it late at night when you can see the tiny sparks earthing against the engine case/frame. If the engine is dry use a small spray gun to lightly mist the wires, you should see faint arcs of electricity as they earth to the case/frame instead of arcing in the spark plug –  Mauro Jun 10 '13 at 19:41
add comment

Sounds like you're on the right track. Water/cold missing issues are usually ignition related. I've been down this road a number of times myself. It can be quite hard to pinpoint. Look for cracked ignition components that might be letting water in/support condensation.

Another (but somewhat remote possibility) is water in the fuel. Bad seal on the gas tank?

share|improve this answer
add comment

I had the same issue. That was because of water getting in carburetor .

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.