Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

This started to happen relatively recent. It's 2003 Chevy Trailblazer. What is happening when the engine is idling and I turn the A/C on or the defroster (which also uses the A/C I believe), the engine starts to bog down.

What could be causing this extra load on the engine? What could it be in the compressor that is so much resistance? Could it be that I just need to recharge my A/C?

share|improve this question
    
Does it only do this at idle or is occuring at highway speeds? –  mikes Mar 11 '12 at 21:00
    
@mikes well it's more noticeable at idle due to the lack of engine load, but I can also feel it at highway speeds. –  Thomas Stringer Mar 11 '12 at 21:19
    
Can you confirm that it's the demisting function of the A/C system (that blows cold dried air on the windshield) and not the rear window heater/demister/defroster thing? –  kahbou Mar 12 '12 at 11:58
add comment

3 Answers

up vote 4 down vote accepted

The compressor is a considerable load on your engine. In order to stop the engine from bogging the A/C usually has a way of raising the idle by letting more air past the throttle body. This function is where I think your problem lies.

This can be a separate solenoid specific to the A/C system with a (fairly hefty) vacuum line to both before and after the throttle body. I've seen this solenoid referred to as an A/C Idle Up Vacuum Switching Valve (VSV) in some manuals, but Chevy's terminology may be different. If it is a separate solenoid, there will also be a separate idle-up solenoid for the power steering as well as for large electrical loads (headlamps, large electric fans, rear defroster). You should find this solenoid, verify that it's not working and replace it.

The alternative, I guess, is that there is one ECU controlled valve that performs the idle-up function for all the systems that require it. In that case, unless your engine also bogs at other times, I would suspect the electrical pathway that informs the ECU of the compressor operating.

Please update your question as you find out more, and I'll add to this answer.

share|improve this answer
add comment

Have your system pressures checked, if the high pressure side is way up it could be putting excess load on the compressor, and if so, make sure the condenser fan is blowing fast enough to pull the correct amount of air to prevent the system from getting too hot and creating too much pressure. This just recently happened on my Honda civic, tapped on the fan a few times and it started bowing a lot harder and the pressures came down to normal

share|improve this answer
add comment

Air conditioning by itself does present a high load - the compressor draws a high current, so the battery needs to be able to provide not only appropriate current for the engine but for the a/c too. If the current is too low, the engine can bog right down

Quick things to check:

  • Battery status - it may be just getting old and not able to provide high current as needed.
  • Spark plugs - if they are old, they may require cleaning/replacing. If they are dirty/worn out they require a higher current to fire.
  • Alternator - is it providing enough current? At highway speeds it should be.
share|improve this answer
    
I really think you should provide your rationale. This, to me, is the equivalent of a stackoverflow answer that just says "Here, paste this bit of code in." –  kahbou Mar 12 '12 at 10:13
    
updated for you. –  Rory Alsop Mar 12 '12 at 10:21
    
The compressor is belt driven, not electrically driven, although the condensor fan is probably quite a large electrical load. –  kahbou Mar 12 '12 at 11:06
1  
Also: The battery does not supply any current while the alternator is working. There is simply no way that a tired battery can cause a low idle, especially not one that only happens when the A/C is running. –  kahbou Mar 12 '12 at 11:08
1  
I don't see how low system voltage could cause a loss of power/idle speed. Fuel pressure is regulated. Spark plugs either work or they don't (misfire). –  kahbou Mar 12 '12 at 11:28
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.