Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

When I engage reverse on the manual transmission of my 2003 Nissan Frontier pickup truck, the reverse lights tend to sporadically turn on and off. I'm trying to figure out what path to take to determine where the fault lies without hopefully having to trace and inspect the wire from the cab to rear of the vehicle looking for points where it is grounding out.

share|improve this question
    
I believe this is one of those 'needle in a haystack' issues. It might in the end be better to run a whole new line from the light back up to either the fuse box or the computer, wherever the line terminates. –  Patrick Mar 11 '11 at 22:42
1  
It's unlikely that this is a short, as a short circuit will usually blow the fuse. What you're seeing is an intermittent open circuit. –  Jay Bazuzi Mar 12 '11 at 0:16
    
Tell us more about the conditions in which this occurs. Hot vs. cold. Running vs. not. Weather. All the time, just sometimes. How quickly does it turn on/off. –  Jay Bazuzi Mar 12 '11 at 3:12
    
@Jay Bazuzi: None of the external conditions of weather or the engine seem to matter. It seems that hitting bumps causes it to go off or come back on. I notice it jar back on or go off if it was on when I'm backing out of the driveway and hit the bump at the street. –  Dougman Mar 13 '11 at 5:12
add comment

2 Answers 2

up vote 4 down vote accepted

There are only a few parts in play here. The reverse light switch in/on the transmission, the wiring to the rear of the vehicle, the tail lamp assembly, and the lightbulb itself.

I would check the bulb first. If the filament is broken in just the right way, it can cause the flashing symptoms that you're experiencing. The part number for the bulb is 3156 (single filament). If that's ok, see if you can get access to the reverse / backup switch in the transmission.

enter image description here

enter image description here

With it still in the car, test it with a multimeter to see if it reliably turns on and off (if you can access it). Alternately, you can unscrew it from the tranny to test it, but I imagine it will be difficult to get at. You may have to remove the shifter boot to access the switch, or you can try to get at it from below.

Does adding extra pressure to the gear knob (holding it in place) help when backing up? If so, that points to the switch being at fault (or to an alignment issue between the gear lever and the switch).

share|improve this answer
add comment

Check the bulb as mentioned here by JeremyP it's quick and easy to eliminate, but it's unlikely because only one of the bulbs would go out if that's the case.

Next set the parking brake, ignition on, trans in reverse. The lights should be working. Now wiggle the wiring harness from the switch where it comes out of the transmission as far up as you can reach while someone is watching the lights in the back to see if they blink on and off. Do the same for the harness running to the tail lights if you make the lights blink the open wire will be in the area where you are wiggling.

If you have a two prong switch as shown in JeremyP's answer you can simply jump across the connector on the harness side (Just make sure you use something small so you don't spread the contacts out or you will create the problem you are trying to fix) back up where you have made the lights blink before and see if they still blink. If so further inspection/repair of the harness will be required. If not it's a safe bet it's the switch, or the adjustment of the switch

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.