Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

Looking for directions on replacing the washer-fluid pump on a 2008 Chevy Equinox. I've found that the fuse works both the pump and the wipers, and the wipers still work. Seeing as I do not hear the pump run I'm guessing it's a failure in the pump.

The pump it's self is at the bottom on the tank. The tank is right in front of the drivers wheel well. But from what I can see I'm not able to access the pump from the wheel well or under the vehicle. I'm also not able to just pull the whole tank as it's got feet that hook under the battery mount.

Any tips or pointers are welcome. Hopefully I've given enough detail.

share|improve this question
    
Did you check the wiring? –  Gabriel Mongeon Jan 10 '12 at 15:30
    
I cant even get down that far to check the wiring. –  Tim Meers Jan 10 '12 at 20:54

1 Answer 1

Everything I've been able to find says the tank has to come out to get at the pump. I'm not sure how to solve the issue with the battery mount. It's probably worth checking to see if you can get at it from the wheel well with the wheel off (might have to to remove the fender liner).

Assuming you can get at the pump, you can verify that it's getting power with a multimeter or a test light. If it's not getting power, the suspects will be the switch/button in the passenger compartment, the relay and a control module, not necessarily in that order.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.