Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

It's happening more and more these days where I will hit the gas while at a complete stop. My car starts moving, but not as fast as it should based on how far I have the pedal down. Anymore, I can sometime nearly floor it and my car just inches its way up to speed, barely accelerating at all, but then it finally shifts gears and my engine goes VROOOOOOOM and my car takes off like a bat out of hades.

Back in the day, I'd hit the gas and my car would go like it should. It only has 50,000 miles on it and I am the only owner. What could cause my car to behave this way?

share|improve this question
2  
Posting at a weekend definitely impacts your views. I have edited out the non-constructive comment you left. –  Rory Alsop Dec 3 '11 at 21:10
    
@RoryAlsop, good edit and I can relate to the frustration of feeling like you're getting low feedback. To answer the edited out question, there are three buttons below the question rating for Google+, Facebook and Twitter. Those are all ways in which you can get additional exposure for this specific question (and the site in general). –  Bob Cross Feb 3 '12 at 23:40

3 Answers 3

If you have been regularly servicing the car, this should not be happening. It could be spark plugs, airflow, fuel or tuning - so unless you have other symptoms you can describe, I'd get those checked out first.

share|improve this answer

Check the spark plug wires to make sure they're installed properly. I saw a case a couple years ago where the car had been in for an oil change and one of the plug wires got bumped loose/out a little. Car idled fine, seemed to drive fine until you asked it to go fast, then it would shudder and bang and just be very unhappy. Found loose wire, pushed it down, all was good again.

share|improve this answer

Are you getting Check Engine Light ?. Most likely it is Spark Plug or Air Mass Flow Sensor.

If i were you I would do following:

  1. Change Spark Plug. Since it is very cheap and easy to replace it and you should change it anyways, there is no waste of money there
  2. If you have check engine light, check the code at Autozone if you do not have OBD2 code reader and get error code and do google on this code.
  3. Buy a Air mass Flow Sensor Cleaner Can and clean MAF. Checkout some of the MAF cleaner Youtube video. It is fairly easy to remove MAF sensor and clean it. DO NOT Touch or clean with anything else. you should only spray this cleaner and let it dry by itself. If you see improvement after cleaning, it is Air mass flow and it is likey you will have to change it to Brand new since it will die after cleaning after you run for couple of days.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.