Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I have a 1968 Ford Thunderbird that had a Mallory ignition. The Mallory ignition started to show signs of wearing out, as the motor would run for a few minutes and suddenly die, only to start back up about 20 to 30 minutes later.

Once it got past the initial start -> die -> wait 20 minutes -> start again cycle, you could go anywhere. You could drive all over the city to the North and South around to the West and back to the East. No problems.

I purchased a replacement and installed it. The car wouldn't start. After more reading, it became clear that the Mallory ignition -- the new one -- was faulty.

The Century Performance Mallory Module Testing Site said that shorts in the electrical system could fry the module. Upon further investigation, I found several disconnected or loose grounds, which I fixed.

The Pertronix and the MSD website take a different approach to their modules. Whereas Mallory claims that it's operator error when a module fries and has absolutely nothing to do with poor engineering, MSD proudly stands behind their product with a warranty and some spike-absorbing materials that protect the module.

Considering that I've fixed the loose grounds that I've found, is it safe to install the Pertronix distributor or an MSD ignition? Are there any tests I can run myself to determine if it's safe to proceed?

share|improve this question
add comment

1 Answer

There is no harm in installing a new distributor and/or new coil. If you want to make sure the ground connection is good, connect a multimeter to the negative terminal on the battery and to the ground terminal on the distributor. It should show very close to 0 ohms (continuity). Wiggle the wires to make sure the connection is solid and inspect the wires for rust, cracks, or corrosion. If they look corroded, replace them. You might also want to check for solid 12V at the distributor, just to be safe. Connect the negative lead of the multimeter to the negative terminal on the battery and the positive lead to the 12V wire for the distributor. Wiggle the wires again. The voltage should stay solid.

Also, can you please elaborate as to why you think the ignition system is at fault? There really isn't much information to go on, aside from the fact the Thunderbird stalls after a few minutes. This could be cause by a number of things. Did you check to see if there was spark when the car stalled? More info is always appreciated. Thanks

share|improve this answer
    
A faulty module can cause the car to stall as described. After stalling and not starting, there was no spark. After waiting the 20 minutes or so, there would be spark. From what I read, these are signs of a faulty module. I also did more tests on the ignition system that pointed to a faulty module. Regardless of the issue, I won't ever do business with Mallory again as they don't stand behind their products. The bottom line is the ignition module is faulty. There are tests you can perform on the module, these failed as well. The tests on the coil showed that the coil was fine. –  jmort253 Mar 14 '11 at 8:04
    
This is great additional info. It sounds like you have the problem accurately pinned down to the ignition module. –  JeremyP Mar 14 '11 at 23:23
    
Thanks, I'm just hoping that an electrical issue in the car doesn't fry the Pertronix. I'll try the multimeter tips you've suggested before installing it. –  jmort253 Mar 15 '11 at 7:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.