Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

High oil pressure in my marine Perkins 4108 diesel showing 80 on the gauge, oil and filters recently changed, wiring checked and ok it runs an alternator to charge the batteries and when disconnected goes back to 35-40psi but it should run the alternator without the pressure going up ?

share|improve this question

closed as too broad by DucatiKiller, Zaid, Rory Alsop, Move More Comments Link To Top Dec 11 '15 at 4:19

There are either too many possible answers, or good answers would be too long for this format. Please add details to narrow the answer set or to isolate an issue that can be answered in a few paragraphs.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Is it an electrical or mechanical gauge? – Timo Geusch Sep 7 '11 at 18:45
1  
Do the RPMs go up? Or is the oil pressure the only thing affected? – FossilizedCarlos Dec 10 '11 at 1:42
    
Did you change the oil weight? – Nick Jun 5 '12 at 4:11
    
when you say disconnected it goes back to 35-40 psi. what are you disconnecting?? is it a 12 vdc or 24 vdc system?? – user2766 Feb 14 '13 at 12:06

Browse other questions tagged or ask your own question.