Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

A few days ago, my Honda Accord 1998 V6 EX's "check engine" light came on. Since then, the engine experiences instability during idle. At stop lights, I can hear the engine having trouble stay running -- it sounds like as if it would stall at any moment.

To diagnose the problem, I bought an On-board Diagnostics (OBD-II) scanner and extracted the trouble code: P0108 (Description: MAP Pressure Circuit High Input).

After doing some research, here's what I've found:

  1. Certain more advanced scan tools (not the one I bought) can display real-time MAP pressure readings from the ECM (engine control module) and this reading can be used to determine whether or not there's a vacuum leak, loose wiring, or defective MAP sensor.

  2. Without the scan tool, one can use a multimeter and hand-held vacuum pump/gauge to determine whether or not the MAP sensor is defective.

For #1, I don't know which scan tool is able to do this and for #2, I don't know how to use a multi-meter.

Am I on the right track?

What can I do to diagnose/fix this problem?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Most of your local mechanics should have the sort of (expensive) scan tool that can display the sensor information. I'd get it diagnosed there - if you're not confident using a multimeter and poking electronics that's probably the quicker way to get a diagnosis.

share|improve this answer
    
Thanks, Timo. Do you know if it's easy to diagnose the MAP sensor with a multimeter? I want to give my best shot at fixing this problem before taking my car to the shop. –  David H Aug 6 '11 at 6:13
    
David, it depends on the type of signal the MAP sensor is putting out, but you'd need the exact specs to check if the measurements that you're seeing are within reason. The OEM workshop manual might show the procedure, or a Honda-specific forum might have a detailed description of it. –  Timo Geusch Aug 6 '11 at 14:40
    
I took my car to a local mechanic and the mechanic was able to determine the cause of the problem (and, yes, they did have the more advanced scan tool that was able to read live data from the MAP sensor). It turns out my MAP sensor was bad. The MAP sensor voltage reading of key-on-engine-off condition does not change after starting the engine. After replacing MAP sensor, the problem just disappeared. Thanks for your help. –  David H Aug 7 '11 at 4:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.