Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I have an older 1993 Mitsubishi Triton ute. The issue is that the reverse lights are always on while the car is running regardless of gear position. The gearbox works, that is to say that the car drives fine.

I have replaced the switch that plugs into the gearbox to check the reverse position with a new genuine one from Mitsubishi. (Which cost way more than I thought it would)

The new switch turns off the lights when pushed down and when let up the lights come back on. (Tested before plugging into the gearbox) This seems backwards to me but that is how it is.

I have checked fuses. I have checked the wiring to the best of my capability.

Since the gearbox seems fine otherwise I am reluctant to think that something might be broken inside it but what else is there?

share|improve this question
    
That renders my comment on your previous question somewhat useless! If the lights are on, then logically the wiring must be fine, a broken circuit or dodgy fuse would result in them being off all the time, and you've proven that the switch works, albeit a bit backwards - have you checked that the old switch does the same? –  Nick C Jul 20 '11 at 8:48
    
:) I'm trying to find the old switch currently to check that. –  Tim Jul 20 '11 at 9:02
    
The old switch is in pretty bad shape.. hence the reason for replacing it in the first place. I can't get a closed circuit from it at all but I am pretty sure that's because it's dead. I'll probably go back to Mitsubishi and find out there is another version of the switch that is actually the right one and they didn't look it up correctly the first time :( –  Tim Jul 20 '11 at 9:27
    
Is there a piece missing - such as an extension, or a hinged arm? This makes it sound like the selector arm is just not pushing the switch down far enough when out of reverse so you need to find out why it isn't being depressed. –  Rory Alsop Jul 20 '11 at 10:23
    
Thanks Rory. I have checked the transmission and cannot find any broken lever arms or anything that looks like there should have been one attached. I have been trying to find some spec's on the transmission but haven't had any luck. AFAIK it seems complete. –  Tim Jul 20 '11 at 21:58

1 Answer 1

Thanks to some helpful people here and on the Australian 4wd forums and a local gearbox repair place I have found a solution.

Apparently the gearbox the the MJ Triton uses a ball bearing above the reverse switch. The gearbox pushes it down (pushing the switch) when in forwards gears which opens the circuit and turns the lights off. In reverse it lifts up and closes the circuit which turns the lights on.

Personally I think that's an absolutely stupid way of doing things but that seems to be the way it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.