Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

My Volvo S40 (06) would not start when I turned the ignition key. I got a message that was somewhat like "Key Error, please try again". I tried with both my keys so it wasn't the key itself. I think I could hear some relay clicking in the on position. I had the same error about a week earlier but then it worked after a few tries and I didn't think more of it, but this time it would not work.

I called the Volvo assistance and the guy they sent put the key into the ignition, turned it fully on and hit it relatively hard about ten times with the handle of a screwdriver, then he turned it to the off position and repeated the procedure.

The car then started. He said that he had fixed this problem on a few Volvos and they seemed to continue working after this, but he could not guarantee anything.

I am not a mechanic (obviously) so I wonder if someone knows what this error could be. Is it just oxidized connectors or is it a symptom of some bigger problem? What can I do about it?

share|improve this question
I had the same problem with my C70 (2006) "key error try later".I tapped the key a few times with a screwdriver handle. The car started first time. –  user3108 May 3 '13 at 13:40

7 Answers 7

up vote 7 down vote accepted

I recently had a similar problem where I got intermittent "Immobilizer" messages.

According to my mechanic (20+ years of Volvo experience) the connector between the antenna ring and the wiring harness sometimes causes problems - taking it off, spraying it with contact cleaner, and re-seating it fixes these. It could be that the vibrations from hitting the key were enough to overcome the resistance and allow the key to be recognized & the car started.

It's a relatively simple job to get to and clean the connector, which might be good preventative maintenance.

Other possibilities: You could have a bad relay. There's a fusebox under the hood, and one of the relays (R13) is for the starter. You should be able to remove the relay, and jumper the connection to determine whether or not the relay is the problem. You can get the wiring diagram for the car here.

Finally, you could have an intermittent connection to the starter, or a bad starter.

share|improve this answer

If you had given that description without the screwdriver part, it would sound to me like your car is one of those that has a chip in the key where not just any key matching the physical cut will work, it has to be in combination with the car reading the chip. The goal being more security to keep someone from getting a hold of your key and making a copy of it or trying to circumvent the physical portion of the ignition.

These were the precursor to the keyless ignitions that are found on more and more cars these days where you don't even have to put the key in, just have it in your pocket.

Perhaps the transmitter/receiver is in the steering column as the key would be in the ignition when it is trying to read it and hitting the key in the ignition caused enough vibration to jossle the transmitter/receiver. Volvo may have had a manufacturing issue on that model of a weak soldering joint or similar causing an intermittent issue to develop over time.

share|improve this answer

I don't know why he would beat on your car, as the problem will likely just return. The problem likely lies in one of these places: The tag in the key itself (RFID) read by the computers, the ring that provides the field required to read the tag, or the computer that recognizes the tag. Beating it fixes nothing.

share|improve this answer

Yes i had a look at a s40 2005 model today, The customer was left with no ignition and no crank but wipers interior light, main lights all worked,

After a lot of tracing i found that the ignition switch to be faulty no main ignition circuit out put, when i used my back probe the car started perfect,all circuits worked,,

This may help i would definitly go to ignition switch first,,

share|improve this answer

Had a similar problem with my 2006 1.8 petrol s40. Immobilizer stuck on, "immobilizer, see manual" error message. I checked all fuses, wiring etc, lock unlock 5 times myth and disconnected my battery for half an hour!

I was on the verge of calling an auto electrician out when I stumbled upon a post that advised me to turn the key all the way to the firing up position and hold it there, then tap the key with the end of a screwdriver, on the third tap my car started. The problem is a loose connection in the starter switch.

share|improve this answer
Do you have a link to that post any more? –  Seminecis Sep 9 '13 at 10:05

Lock and unlock the door 5 times. See this post: http://www.harikari.com/technology/volvo-xc70-immobilizer-see-manual.html

share|improve this answer
Welcome to the site. We're glad you found us. When posting, if you actually give the instructions and exactly why to do this, your answer will be better accepted. Attributing is a very good thing, though. It's just good to have all the information here in case the linked site becomes defunct for any reason. –  Paulster2 Apr 8 '14 at 10:32
Thanks, I'm new to this. I had my car towed to the dealership because they wouldn't give me this information over the phone. My son had just been born and, after finding and trying an old set of keys I'd had replaced, I had to arrange for a friend to drive my wife and newborn home from the hospital while I went to the dealership. When I got there in the tow truck, the mechanic locked and unlocked the door five times with the remote and was able to start the car immediately. –  TonyJ Apr 10 '14 at 5:47
Sorry, meant to add that trying to open the car with a lost remote enables the immobilizer security feature. If you have a valid remote, you can reset the immobilizer with it. –  TonyJ Apr 10 '14 at 5:55

I had the same problem this morning with my 2007 s40 2.0D. The car has 125,000 miles on the clock and up until now has been very reliable.

I went on a short journey this morning parked the car as normal and locked it with the key fob. On my return the car unlocked with the key fob, but when I tried to start the engine the radio & dash board operated as usual however when I turned the key to position 3 the engine would not turn over.

When the key was turned there was no sign that anything was happening, no clicks from the starter motor or audible noise from the fuel pump etc.

I had to leave the car there and went home to check the web to see it this had happened to anybody else, and I stumbled on this site, I decided to try this remedy as I had nothing to lose, and to my surprise it worked.

I held the key in position 3, then hit the end of the key firmly with a screwdriver handle, and the car started.

Try it, it worked for me!!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.