Take the 2-minute tour ×
Motor Vehicle Maintenance & Repair Stack Exchange is a question and answer site for mechanics and DIY enthusiast owners of cars, trucks, and motorcycles. It's 100% free, no registration required.

I installed a car stereo a few months ago and it seems to forget all of its settings whenever it loses power. The stereo the car came with didn't have this issue. I am familiar with electronics so I am assuming it needs a constant power source to keep the memory in-tact, however the ponytail connector is different than that of my cars, I had to splice wires to get it to work. There are 2 power cables that supply power and I have tried both and neither seem to do the trick (only 1 combination works as the ampage is different).

Is there a way I can possibly rig a small battery to one of the cables or something so that there is a constant power supply going to the radio? Or perhaps the battery in the stereo itself (if it has one) is dead?

The car is a Sukuki Swift 2006 plus

The stereo is a TKO BH-MP180

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Typically car stereos do require a constant voltage source in order to keep settings - they may have a supercap which keeps settings for a short while (for changing batteries over etc), but over time this may degrade, and in any case is only designed to last for a few minutes.

In order to do this you usually have an unswitched power wire directly from the battery, as well as a switched lead (on when the ignition is on)

The current draw should be low when the stereo is off, so it shouldn't drain a good battery quickly.

Update from your comment: Measure the voltage on the leadsw powering your radio. One should be 12 volts all the time, the other should be 0v normally and 12 volts when the engine is running (pretty certain the Swift is negative ground). If neither is giving you continuous 12 volts then that is your problem - the solution is to wire the continuous power lead direct to the car battery.

share|improve this answer
    
I am not worried about it draining my car battery. I just want the thing to remember its settings. I am pretty sure the wiring is fine and it's the radio itself. Should I try to take apart the radio to see if there's a battery inside of it? –  qroberts Jul 5 '11 at 14:53
2  
Based on your question you don't need to worry about the battery inside it - you need to worry about the wiring. Use a multimeter to see if one of your power wires provides continuous 12 volts. If not, that's your problem. –  Rory Alsop Jul 5 '11 at 15:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.